Windows Hardening  V16

 To start a command promt: in the application search enter: cmd → then select “cmd”

If you need to run “cmd” as administrator, then right click on “cmd” and select “Run as administrator”
0) Read the forensic question and the instructions first!!!!

1) Access to control panel – not a hardening thing, but some of the GUI steps below indicate starting from control panel
· cmd window: control

· Application search enter: contr → then select “Control Panel”

· Window button → “Windows System” → “Control Panel”
2) Determine what version of windows is running – version is useful if you need to google something.
· cmd window: winver
· Application search enter: vers → select “System Information”

· from Control Plannel: Control Panel->System and Security->System

2.5) determine who you are logged in as
· cmd window: whoami

3) Check Users and their privileges 


Remove any user not identified as being a valid user of the system


Make sure only users identified in instructions to be administrators are set as administrators


Disable the Guess Account if it exist and is active


Set a complex password for all users, use something like:  Cyb3rP@triot!


You must remember any password you set so you can login!!!


Ways to access tools for taking these actions (This is good tool to see which accounts have passwords set):

· cmd window:  control  /name Microsoft.UserAccounts → Manager another account

· Application search enter: account → then select “User Accounts”

· W10 GUI: control panel->User Accounts ->User Accounts->Manage another account


Get list of users in the Administrators group
· cmd window:  net localgroup administrators


Local user management  is a great tool for managing user accounts and groups– It's good to see what groups a user is in or what users are in a group!

· cmd window:  lusrmgr.msc

Rename the default accounts
Using lusrmgr Should should also rename any built in accounts such as Administor to myAdministator, Guest to myGuest, and DefaultAccount to myDefaultAccount. Do not change WDAGUtilityAccount name.   Using lusrmgr you should make sure Administrator, Guest and DefaultAccount are disabled.  WDAGUtilityAccount is part of Defender application guard and should be enabled if you enabled application guard.


Check guest group – Only Guest user should be in Guest group.
4) Control when notifications of system changes are provided


Notifications should be set to “Notify me only when apps try to make changes to my computer (default)
· cmd window: UserAccountControlSettings
· Application search enter: User    → then select “Changer User Account Control settings”
5.0) Check group policy items


Policy items can be set under group policy that might cause you issues when hardening the system.  So start the group policy editor
· cmd window: gpedit.msc

Check for items set by selecting “Computer Configuration→ Administrative Templates → All Setting”.

Click on the State tab heading to see items that are configured.  Windows only set a couple of  of these by default so any that are set could be suspect.  Figure out what the item does and decide if you should change it.

Do the same for User Configuration→ Administrative Templates → All Setting”
One key in particular to pay attention to is “User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy\Group Policy snap-in extensions\Security Settings”.  If this is disabled you can not modify the local security policy via secpol or gpedit.  As such you probably want to set it to “Not Configured”
5) Set a password policy

Set – Minimum Password length to 10 or more,  Maximum password age 90, Minimum password age 5, Password must meet complexity requirements to enable, 10 for enforce password history,  Store passwords using reversable encryption to disabled.
· cmd window: secpol.msc    then Account Policies → Password policy

· Application search enter: sec  → then select “Local Security Policy”
· From control panel->system and security->administrative tools->local security policy

Note if secutiy policy options are not available then they were probably disabled via a group policy setting.  In cmd window run group prolicy editor: gpedit
Make sure the tag
“User Configuration\Administrative Templates\Windows Components\Microsoft Management Console\Restricted/Permitted snap-ins\Group Policy\Group Policy snap-in extensions\Security Settings”  is not disabled.
5.5) Set password lockout policy

Set Account lockout threshold to 6 and it will give pop up to set other variables, select OK

· cmd window: secpol.msc    then Account Policies → Account Lockout policy

· Application search enter: sec  → then select “Local Security Policy”

· GUI: control panel->system and security->administrative tools->local security policy

Note below in the “Some additional tools that might be useful.” section there is a single line that will set password related policy items, with the exception of password complexity.  

6) Disable remote desktop access

unless secinario instructions stated remote desktop is used to administer the machine, you want to disable it.

· cmd window: control system → Remote settings

· Control Panel->System and Security→System→Remote settings
· Application seach → “System” → “System” →Remote settings

There are a bunch of policy items associated with remote desktop in the group policy editor under “Computer Configuration → Administrative Templates → Windows Components → Remote Desktop Services”.  You might wan to to look at items to enable or disable, such as “Remote Desktop Connection Client  → Do not allow passwords to be saved”   and “Remote Desktop Session Host →Devices and Resource Redirection → Do not allow supported Plug and Play device redirection”.  
6.1) Disable remote assistant reguardless of where you keep remote desktop access on in step 6

The Remote setting link on left provides option to disable remote desktop access

You can also access information about OS version and hardware and other items


Un check “Allow Retmote Assistance ...” and check “Don’t allow remote connection …”

In an administrative command window make sure if Remote Desktop is used the session is encrypted

# Require encrypted RPC connections to Remote Desktop

reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services" /v fEncryptRPCTraffic /t REG_DWORD /d 1 /f

# Prevent sharing of local drives via Remote Desktop Session Hosts

reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services" /v fDisableCdm /t REG_DWORD /d 1 /f
7) Update any application that scenario indicates is a required application
It’s pretty normal for the senario to indicate a few applications are default applications and must be running the latest version.  A couple of examples that are mentioned in the ReadMe are FireFox and Notepad++.  Any application that you are told in the readme must be the latest, needs to be updated.  Most of these apps will have an update option off the help or about screen.  For example you can update FireFox by clicking the hamburger menu → help → about Firefox.  At this point there is an option on the screen to update Firefox.

Note:  Just because the application indicates there is no update does not mean you are running the latest.  Check the site that provides the application to make sure you have the latest version.  Only download application from the owning company site.  i.e. Firefox comes from the mozilla site.
8) Look for installed programs that you want to uninstall and features you want to disable
Note: Nomally installed applications will be placed in  Program Files or Program Files (x86).  When you remove an applications via appwiz you should make sure all files associated with the application are also removed from these two dirctories.  

· cmd window: appwiz.cpl  
· From Control Panel->Programs->Programs and Features

Any installed applications that seems to be contrary to secenario instructions should be removed
· From “Turn Windows Features on and off” link: unless instructions indicate it is needed,  disable telnet, web, FTP, SNMP services and simple TCPIP services (echo, daytime) are enabled under features.  Web and FTP are under “Internet Information Services”

· You should also use file explore to navigate to “C:\Program Files” and “C:\Program Files (x86)”  to look for applications that were installed in a non-standard way that you might want to delete.  Instead of deleting anything you should probably just rename the directory.
Note:  If you have a application installed on the system that doesn’t show an option to remove it you have a few options

1) If it’s a common application you could try installing the latest version and then uninstalling the version you installed

2) You can delete the applications file.  If the application is running you will need to kill it before you can remove the application files.

9) Access Windows action center

Action center points out important items that should be addressed, such as enabling firewall

· cmd window (Win10): wscui.cpl 

· cmd window:  control  /name Microsoft.ActionCenter → Change User Account Control Settings

· W10 Application search enter: security → select “Security and Maintenance 
Other Options available here!!!

· “Change Security and Maintenance” link lets you change security notifications: Enabled all messages by checking the check boxes.

· “Change User Account Controls” lets you set notifications for app changes: Should have done it based on previous instructions, but if you didn't make sure set to the (default) level

· Windows smart screen can be enabled

There are two registry key that can disable windows notifications that you should make sure are disabled, the line wraps here:
· Set-ItemProperty -Path "HKLM:\SOFTWARE\Policies\Microsoft\Windows\Explorer"  -Name DisableNotificationCenter  -Value 0 -Type Dword

· Set-ItemProperty -Path "HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\PushNotifications"  -Name ToastEnabled  -Value 1          -Type DWord
10) Require password to login
cmd window: netplwiz then  User tab → “User must enter username and password” check box
Note: On the latest version of windows 10 this box is greyed out and you need to change a registry value to disable the auto login.  From powershell enter the following:

set-itemproperty "HKLM:\software\microsoft\Windows NT\currentversion\winlogon" "AutoAdminLogon" -value 0

Same app for item 11
11) Require <CTRL><ALT><DEL> to log in and a few other items
     Note for Windows 2016 you have to access local security policy via windows search for local
      Method 1

· cmd window: netplwiz   then  Advance tab → Secure sign-in check box “Require … Ctrl+Alt+Del”
      Method 2 
· Application search enter: sec  → select “Local Security Policy” → Local Policies → Security Options → “Interactive login: Do not require CTRL ALT DEL” → disabled

While you're in the “Local Security Policy” tool you should also disable a few other items
    “Local Security Policy” → Local Policies → Security Options → 
“Accounts: Guess account status” → disabled

“Accounts: Rename administrator account” → Jimmy

“Accounts: Limit local account use of blank passwords to console login only” - > enable

“Interactive logon: Display user information when the session is locked ” → Do not display user information

“Interactive logon: Do not require CTRL+ALT_DEL” → disabled
“Interactive logon: Do not display user name at sign-in” → enable

“Interactive logon: Do not display last user name ” → enable

“Microsoft network client: Digitally sign communications (always)” → enabled

“Microsoft network client: Send unencrypted passwords to third party SMB servers” → disabled

“Microsoft network server: Digitally sign communications always” → enabled

“Network access: Do not allow anonymous enumeration  of SAM acccounts” → enabled

“Network access: Do not allow anonymous enumeration  of SAM acccounts and shares” → enabled

“Network security: LAN Manager authentication level” → send NTLMv2 response only

“Network security: Do not store LAN Manager hash value on next password change” → enabled

“Network security: Do not allow storage of passwords and credentials for network authentication” → enable

“Shutdown: Allow system to be shut down without having to log on ” → disabled

“User Account Control: Detect application installations and prompt for elevation ” → enable
Note: Last section that starts on page 9 of this document gives provides a way to set a lot of these options from the command line. 

12) Enable screen saver 

· Application search enter: screen sav → “Turn screen saver on or off”

· Pick screen saver, how long to wait before it's activated and check box “On resume show login screen”

12.1) Disable media auto play
· Application search enter: autoplay → “AutoPlay settings

· Set “Usee AutoPlay for all media and devices” to off

13) Look for unauthorized files
· Using file Explore, first navigate to C:\Users   and then click on each user's directory, finaly click back to C:\Users

· Win7  select Organize→Folder and Search Options→ View Tab → click “Show hidden files ...”

· Win7 Hit the apply button
· Win10 → View tab → check box “Hidden items”

· Then in search field

· 
For music enter:   kind:=music

· 
For movies enter:   kind:=movie

· 
For videos enter:   kind:=video

· 
For programs enter:   kind:=program

· 
For compress files enter:   .zip
·            For compressed files also try:  7z
14) Enable Windows Defender visus scan
1. Enable and Run virus scan

· Application search enter: defender → “Windows Defenders Setting”  → select “Real time protection” on 


Run Windows Defender scan 

· Application search enter: defender → “Windows Defender desktop app” → select Scan Now

Note: like Windows updates this service can be disabled in a number of ways

1. From the Service application Windows Defender can be disabled so you might need to re-enable it.

2. From gpedit → Computer Configuration → Administrative Template → Windows Components → Microsoft Defender Antivirus → Turn off Microsoft Defender Antivirus -> set to disabled

3. From powershell you could try the following command to enable defender

· Set-MpPreference -DisableRealtimeMonitoring $false

4. There are a couple of regestry keys that might have been modified and from powershell you can fix them by running the following powershell commands.  These commands are wrapping in the editor here and the Disable…. part is really on the same line right after -Name
· Set-ItemProperty -Path "HKLM:\SOFTWARE\Policies\Microsoft\Windows Defender"  -Name DisableAntiSpyware    -Value 0 -Type Dword

· Set-ItemProperty -Path "HKLM:\SOFTWARE\Policies\Microsoft\Windows Defender"  -Name DisableRoutinelyTakingAction -Value 0 -Type Dword


After setting these values you probably need to reboot the systems before virus scanning will start.

If you still can’t get it running you should run system updates and see if it’ll run after the updates.

You should also consider enabling use of sandboxing for Windows defend.  In cmd window that you ran as administator enter the command: setx /M MP_FORCE_USE_SANDBOX 1

14.5) Make sure event log and Windows Defender Firewall services are enabled and running
· Application search enter: services → Services App → 

· make sue “Windows Event Log” is set to Automatic and is Running

· make sue “Windows Defender Firewall” is set to Automatic and is Running
15) Turn on  “App & Browser control” which helps secure browsing and watch for bad apps
· To enable, in application search enter: App & bro → select “App & browser control”.  Enable Reputation-based protection.  If any other items are available to enable, then enable them. 

15.1)  If Firefox is on the system set security items off the Firefox hamburger menu->Privacy&Security

· Block pop-up windows

· Warn you when websites try to install add-ons

· Block dangerous and deceptive content

· Block dangerous downloads

· Warn you about unwanted and uncommon software

· Enable HTTPS-Only Mode in all windows  

· Check add-ons and look for extensions and plugins that are installed.  Unless readme says otherwise, just remove any extenstion and plugin.

16) File sharing should be disabled unless scenario states otherwise
  
The following assuming the scenario doesn’t indicate sharing is used
· Application search enter: sharing → select “Manage advanced sharing setting”

· Under Guest or Public select  “Turn off network discovery”

· Under Guest or Public select  “Turn off file and printer sharing”

· Under Private select  “Turn off network discovery”

· Under Private select  “Turn off file and printer sharing”

· Under All networks select “Turn off Public folder sharing”

· Under All networks select  “Turn on password protected sharing”

16.5) Remove any file shares
· Application search enter: Computer → Computer Management ->Shared Forlders → Shares

· Highligh a share name in the middle panel, then select Action → Stop Sharing

     Note: ADMIN$, C$ and IPC$ are defaults you shouldn’t need to change.

17) Fully enable windows firewall
· cmd window: wf.msc

· Application search enter: firewall → Windows Firewall with Advanced Sharing

· The select “Windows Firewall Properties” link

· Enable Firewall under Domain profile, Private Profile and Public Profile tabs

· Best practice is for Inbound Connections to be “Blocked”
18) Look for scheduled task you might want to end then disable or delete
· cmd window: taskschd.msc

· Application search enter: task → Task Scheduler


Click “Task Scheduler Library”. 


Top center box will have a list of the scheduled task you should review.  Look for running task.


To end, disable or delete a task, right click on the task name to get the menu.

19)  Disable Remote Registry editing

· application search enter: service → Services 

· In list of services fine “Remote Registry”, double left mouse click on the line

· If Startup full down list not set to Disabled then set to Disabled and click Apply button

· If  status shows it is running, then clink on Stop button
20) Enable auditing

· Application search enter: sec  → select “Local Security Policy” → Local Policies → Audit Policy → 

· Select each “Audit” line and Click both the Success and Failure check boxes and click OK
· Application search enter: sec  → select “Local Security Policy” → Advanced Audit Policy Config ->
· System Audit Policies:  There are a lot of additional audit things you can turn on here.  I’d recommend you enable everything for Success and Failure

· Application search enter: gpe → Edit group policy→ Computer Configuration → Windows Settings → Security Settings → Advanced Audit Policy Configuration → System Audit Policies  → Local Group Policy Object → System → Audit Security State Change → Configure for success and failure

21) Check running processes and look at listening ports with resource monitor
· cmd window: resmon
· Application search enter: resmon → then select resmon

You want to click the network tab and then make sure the “Listening Ports” window is expanded.  You probably want to sort by image name.  I'd ignore anything provided by svchost. For all other image names search on google to see if they seem like they might be of concern.  


Bring up you web browser and go to live.sysinternals.com  download autoruns64.exe and procexp.exe.  Once they download, select the open folder option.  Then run both tools as administrator.  You do this by right clicking on the file and selecting “run as administrator”.  
For the Autoruns application select the Options menu → scan options → Then check  “Verify code signatures” and “Check VirusTotal.com.   Select “Options” → Hide Microsoft entries.   At a minimum you want to look at the Logon, Scheduled Tasks, and Services tabs.  

Pink lines do not have valid signatures and should be the first thing you look at!

If you double click a line it takes you to the location where the application is started.  Be careful if you end up in the Registry Editor application as you can cause real damage here.  In the Autoruns window, unchecking a box next to the application will stop it from starting on next reboot.  

For the Procexp application select the Options menu → Verify Image signatures  

Then select Options menu → VirusTotal.com → CheckVirusTotal.com

Click on “Verified Signer” column to sort so entries that are not verified are on the top.

The items with (No signature was present in the subject) are the items of most interest.  

Clicking on the process name may give the command line used to start the application, it's path and in some cases the Autostart Location.   This information can be used to remove a process.

Note: Windows has a commandline tool for looking at listening ports but it’s not as effective as resmon.  If you want to try it out run:  netstat –ano ¦find /i  "listening"
22) Enable windows updates and run updates
We wait to run updates as it can take some time to finish and make the system run slow, while posibly requiring multiple long reboots.  However don’t to wait until time is almost out.  Make sure you run this step at least 1 hour before the competition is over.
Windows updates can be disabled in a number of ways that you may need to fix before you can run any updates.

1. The “Windows Update” Service could be disabled off the Services disktop app.  Bring up the services app and make sure “Windows Update” → Startup type is set to Automatic and the Service Status is Running

2. Group policy can disable auto updates.  Via gpedit → Computer Contiguration → All Settings → sort on State and see if “Configure Automatic Updates” is disabled.  Change to Enable to enable running of windows software updates
          Note- since windows 10 you can’t disable auto updates using the normal GUI, you can only pulse and set time they will run.  You should manual run updates.
· cmd window control  /name Microsoft.WindowsUpdate

· Application search enter: update → then select “Check for updates”
Note: Windows 10 does not allow disabling auto updates.  From application search: update → “check for updates”  gives option to look for updates now!    

Note: As Windows updates are implemented as a service and the associated service can be disabled, so if you may need to make sure the “Windows Update” service is enabled!

Note: Server 2016 and maybe Server 2019 has a nice commandline tool,  if you need to enable or disable updates in cmd prompt enter: sconfig → option 5 → M for manual.
Note: Some version of windows update have “Defer feature updates” under “advanced options” 


After running updates if they fail you can run the troubleshooting tool  available via the control panel to see if you can fix the issue with the update.  

· Application search enter: trouble → then select Troubleshooting→System and Secuity→Fix problems with Windows Update)

22) Disable some services tied to your network adaptor
Bring up control panel then select: Network and Internet → Network and Sharing Center → Change adaptor settings

Right click on the network device → Properties

uncheck the following
Client for Microsoft Network

File and Printer Sharing for Microsoft Networks

QoS Packet Scheduler

Microsoft LLDP Protocol Driver

Internet Protocol Version 6 

Link-Layer Topology Discovery Responder

Link-Layer Topoplogy Discovery Mapper I/O Driver

Double click on “Internet Protocol Version 4 → Advanced 

DNS Tab, uncheck Register this connection address in DNS

WINS tab, Disable NetBIOS over TCP/IP

23) Look for files set for access by everyone
Micosoft has a set of tools called sysinternals.  The AccessChk tool run in a powershell window can find files set with permission for everyone.  The tool is available here:


https://learn.microsoft.com/en-us/sysinternals/downloads/accesschk
You have to download it and unzip the file.  You then start a powershell window as admin.  You need change directory in powershell to the location where you unzipped the application.  Then run the following:


.\accesschk -s everyone c:\ | select-string -casesensitive “RW”
This will give you a list of files that everyone can read and write.  You would need to deside if any of these seem unreasonable, and if so you would need to modify the file/directory permission.  An FTP directory that allows anyone to read and write might be questionable.  
24) Set a few Attack Surface Rules (ASR)
# Block Office Child Process Creation 
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids D4F940AB-401B-4EFC-AADC-AD5F3C50688A -AttackSurfaceReductionRules_Actions Enabled
# Block Process Injection
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids 75668C1F-73B5-4CF0-BB93-3ECF5CB7CC84 -AttackSurfaceReductionRules_Actions Enabled
# Block Win32 API calls in macros
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids 92E97FA1-2EDF-4476-BDD6-9DD0B4DDDC7B -AttackSurfaceReductionRules_Actions Enabled
# Block Office from creating executables
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids 3B576869-A4EC-4529-8536-B80A7769E899 -AttackSurfaceReductionRules_Actions Enabled
# Block execution of potentially obfuscated scripts
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids 5BEB7EFE-FD9A-4556-801D-275E5FFC04CC -AttackSurfaceReductionRules_Actions Enabled
# Block executable content from email client and webmail
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids BE9BA2D9-53EA-4CDC-84E5-9B1EEEE46550 -AttackSurfaceReductionRules_Actions Enabled
# Block JavaScript or VBScript from launching downloaded executable content
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids D3E037E1-3EB8-44C8-A917-57927947596D -AttackSurfaceReductionRules_Actions Enabled
# Block lsass cred theft
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids 9e6c4e1f-7d60-472f-ba1a-a39ef669e4b2 -AttackSurfaceReductionRules_Actions Enabled
# Block untrusted and unsigned processes that run from USB
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids b2b3f03d-6a65-4f7b-a9c7-1c7ef74a9ba4 -AttackSurfaceReductionRules_Actions Enabled
# Block Adobe Reader from creating child processes
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids 7674ba52-37eb-4a4f-a9a1-f0f9a1619a2c -AttackSurfaceReductionRules_Actions Enabled
# Block persistence through WMI event subscription
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids e6db77e5-3df2-4cf1-b95a-636979351e5b -AttackSurfaceReductionRules_Actions Enabled
# Block process creations originating from PSExec and WMI commands
powershell.exe Add-MpPreference -AttackSurfaceReductionRules_Ids d1e49aac-8f56-4280-b9ba-993a6d77406c -AttackSurfaceReductionRules_Actions Enabled
25) Enable screen saver – Part is redundant to steps done above, that’s ok
From adminstrative command window or powersheel window execute these reg lines
# Set screen saver inactivity timeout to 15 minutes
reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" /v InactivityTimeoutSecs /t REG_DWORD /d 900 /f
# Enable password prompt on sleep resume while plugged in and on battery
reg add "HKLM\SOFTWARE\Policies\Microsoft\Power\PowerSettings\0e796bdb-100d-47d6-a2d5-f7d2daa51f51" /v ACSettingIndex /t REG_DWORD /d 1 /f

reg add "HKLM\SOFTWARE\Policies\Microsoft\Power\PowerSettings\0e796bdb-100d-47d6-a2d5-f7d2daa51f51" /v DCSettingIndex /t REG_DWORD /d 1 /f
26) Disable Auto Run on Removal Media – May be redundant to steps run above, that’s ok
reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows\Explorer" /v NoAutoplayfornonVolume /t REG_DWORD /d 1 /f
reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer" /v NoDriveTypeAutoRun /t REG_DWORD /d 255 /f

reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer" /v NoAutorun /t REG_DWORD /d 1 /f
27) SMB hardening
From adminstrative command window or powersheel window execute these run lines

powershell.exe Disable-WindowsOptionalFeature -Online -FeatureName smb1protocol -norestart
reg add "HKLM\SYSTEM\CurrentControlSet\Services\mrxsmb10" /v Start /t REG_DWORD /d 4 /f

reg add "HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" /v SMB1 /t REG_DWORD /d 0 /f

reg add "HKLM\SYSTEM\CurrentControlSet\Services\LanManServer\Parameters" /v RestrictNullSessAccess /t REG_DWORD /d 1 /f

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Lsa" /v RestrictAnonymousSAM /t REG_DWORD /d 1 /f

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Lsa" /v RestrictAnonymous /t REG_DWORD /d 1 /f

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Lsa" /v EveryoneIncludesAnonymous /t REG_DWORD /d 0 /f

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Lsa" /v RestrictRemoteSAM /t REG_SZ /d "O:BAG:BAD:(A;;RC;;;BA)" /f

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Lsa" /v UseMachineId /t REG_DWORD /d 1 /f

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Lsa" /v LimitBlankPasswordUse /t REG_DWORD /d 1 /f

reg add "HKLM\SYSTEM\CurrentControlSet\Control\LSA\MSV1_0" /v allownullsessionfallback /t REG_DWORD /d 0 /f

reg add "HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" /v EnableSecuritySignature /t REG_DWORD /d 1 /f
26) Consider setting more of the security options under Local Security Policy
Under Local Security Policy→ Security Settings → Local Policies → Security Options  there are a lot of additional security options you could try to set.  Look at what they do, figure out if enabled or disabled provides the protection and set the value.  
27) Download and install malwarebytes free scanning tool

NOTE, this should be the last thing you do as it may possibly quarantine the scoring software.  If it does you can tell the tool to move the file back in place and set it up to ignore the scoring files are future scans.
This tool can be found at https://www.malwarebytes.com/mwb-download/
Install and run the program.  If it finds anything select the Quarantine button, but first try to identify any score files and uncheck them.  

Some additional tools that might be useful. 

To deal with OOBE issue on login you can disable it in gpedit via:
Navigate to Computer Configuration > Administrative Templates > Windows Components > OOBE. Double click on the Don’t launch privacy settings experience on user logon policy to edit it. 
Direct access to Security and Maintenance tool
· cmd window:  wscui.cpl → Security
This gives access to Network firewall, Virus protection and User Account Control setings
List applications stated by registry run keys
· In Admin cmd window: wmic startup list brief
Command window list running processes
· In Admin cmd window: wmic process list brief
· List every second: wmic process list brief /every:1
· List and filter: wmic process list brief /every:1 | find "cmd.exe"
Run system file integrity checking
Helps restore corrupt operating system files. 

Start a command window as administrator and run:  sfc /scannow
Direct access to admin tools, include firewall, task scheduler, resource monitor and event view
· cmd window: control /name Microsoft.AdministrativeTools 
· cmd window: control admintools 
· Application search enter: admin → then select “Administrative Tools
· W7 GUI: Control Panel->System and Security->Administrative Tools

· Windows firewall and advance security, can enable disable firewall by lan location

· Task Scheduler let you see what is running

· Services lets you control running services

· Resource Monitor can check processes and look at listening ports
Look at processes running with Task Manager
· cmd window: taskmgr 
· Application search enter: taskm → then select “Running processes with Task Manager
· Note: Task Manager for windows 8 and 10 include:

· Start up tab provides list of apps stated on start up and can be disabled here

Get your IP address and other ip related information
· cmd window: ipconfig
Examine System logs, security log would be most relevant 
· cmd window: eventvwr
A lot of the above can be accessed via the tools tab on msconfig, msconfig also gives access to applications that start at boot
· cmd window: msconfig
Access group policy editor
· cmd window: gpedit.msc
Access system properties – Remote desktop control, System Restore points, Computer name/Workgroup:
· cmd window: sysdm.cpl
Verify integrity of system driver files
· cmd window: sigverif

Look for system files that have been modified, you need to restart after running this in cmd window
· sfc/scannow
Another windows system integrity checking, run cmd as administator
· DISM /Online /Cleanup-Image /ScanHealth
If errors are found then run
· DISM /Online /Cleanup-Image /RestoreHealth
The net command available from the command prompt can be used to do a number of things such as
Set password policy, this is one long command, not three lines. Note you can’t enable password complexity here
net accounts /minpwlen:10 /maxpwage:90 /minpwage:5 /uniquepw:10 /lockoutthreshold:5 /lockoutduration:30 /lockoutwindow:30
Set user password
net user USERID NEWPASSWORD
Force user to change password on next login:
net user "USERID" /logonpasswordchg:yes
Export/import local security policy:
     Use secedit to dump policy, notepad to change and secedit to load it back in.  Start powershell as admin then use the following commands:
           cd  ~
secedit /export /cfg .\secpol.cfg
notepad .\secpol.cfg
secedit /configure /db c:\windows\security\local.sdb /cfg .\secpol.cfg /areas SECURITYPOLICY
Some values you might change in notepad:
           Under System Access
MinimumPasswordAge = 5

MaximumPasswordAge = 90

MinimumPasswordLength = 10

PasswordComplexity = 1

PasswordHistorySize = 10

LockoutBadCount = 5

ResetLockoutCount = 30

LockoutDuration = 30
ClearTextPassword = 0

Under Event Audit:
AuditSystemEvents = 3

AuditLogonEvents = 3

AuditObjectAccess = 3

AuditPrivilegeUse = 3

AuditPolicyChange = 3

AuditAccountManage = 3

AuditProcessTracking = 3

AuditDSAccess = 3

AuditAccountLogon = 3
Under Registry Values:
MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableCAD=4,0                    

MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System\DontDisplayLastUserName=4,1

MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System\DontDisplayLockedUserId=4,3 

MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System\DontDisplayUserName=4,1          

MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System\EnableInstallerDetection=4,0

MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System\ShutdownWithoutLogon=4,0

MACHINE\System\CurrentControlSet\Control\Lsa\LimitBlankPasswordUse=4,1

MACHINE\System\CurrentControlSet\Services\LanManServer\Parameters\RequireSecuritySignature=4,1

MACHINE\System\CurrentControlSet\Services\LanmanWorkstation\Parameters\EnablePlainTextPassword=4,0 

MACHINE\System\CurrentControlSet\Services\LanmanWorkstation\Parameters\RequireSecuritySignature=4,1
                            MACHINE\System\CurrentControlSet\Control\Lsa\LmCompatibilityLevel=4,3
                            MACHINE\System\CurrentControlSet\Control\Lsa\RestrictAnonymous=4,1   

Seach for files with a specific extention via command line:
dir  /b  /s   c:\users\*.mp3

Query an open port
    Microsoft has tool called portqry that you can download from:
https://www.microsoft.com/en-us/download/details.aspx?id=17148
The tool allows you to interact with an listening port on a machine.  
Microsoft sysinternals
Alternative tools for a lot of microsoft built in administrative tools.  Available from:
https://learn.microsoft.com/en-us/sysinternals/ or
https://technet.microsoft.com/en-us/sysinternals/bb545027.aspx  
Search for sysinternals suite and the above link should come up.  Lots of tools, however the best ones are process explore, procexp.exe and autoruns.  Process Monitor and TCPView are also handy.  You want to run it as administrator so you can check virus total 

Autoruns
See what programs are configured to startup automatically when your system boots and you login. Autoruns also shows you the full list of Registry and file locations where applications can configure auto-start settings.

Has options to do VirusTotal scan and check signatures.  You then can filter based on results

Process Explorer
Find out what files, registry keys and other objects processes have open, which DLLs they have loaded, and more. This uniquely powerful utility will even show you who owns each process.

Best tool as it lets you check signatures on executable and virus total.  Can click on process to see how it is started and look at strings and other things.

Process Monitor
Monitor file system, Registry, process, thread and DLL activity in real-time.

Should be able to find process that resets a file or registry entry

TCPView
Active socket command-line viewer.

ShareEnum
Scan file shares on your network and view their security settings to close security holes.
Useful Powershell commands:

1. Find a file in some part of the directory structure within a powershell window:
get-childitem - r  -force  -EV Err  -EA SilentlyContinue -path c:\users  SEARCH_TERM
   replace c:\users if you desire to look in some other location and replace SEARCH_TERM with name you’re looking for.
Scheduled tasked

· schtasks

Edit the windows Registry, potentially to stop bad process from starting on reboot

· Registry Editor: regedt32

Admin tools that may be usefule
Restore system to earlier point: rstrui – Do not use in competition!!!!

Tools that don't appear to be useful
Performance monitor:  perfmon
Resources
https://www.lifewire.com/administrative-tools-2625804
https://www.lifewire.com/list-of-control-panel-applets-in-windows-2626120
https://www.lifewire.com/task-manager-2626025
https://www.lifewire.com/how-to-open-control-panel-2625782
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